Back to overview
Degraded

DoS Attack against our booking system

May 20 at 01:20pm BST
Affected services
Dashboard
Forms
API

Resolved
May 20 at 03:47pm BST

Patches have rolled out and system is back to 100% stability.

We will continue to monitor throughout the day, please report if you are still observing performance issues with your account.

Created
May 20 at 01:20pm BST

We've identified a large increase in malicious activity across our booking platform which is affecting the stability and performance of some customers.

We've identified the source and are working to mitigate this and restore full functionality.