Appointments being created without attached patient data
Resolved
Aug 28 at 08:00pm BST
The engineering team have confirmed all data for the affected period has now been restored to their intended state and there was no data loss for appointments or patients.
Some attempts to create appointments via the dashboard may have failed when manually creating appointments for new patients within the affected timeframe. All appointments created via form submission or the API were not affected and will appear in your calendar view as expected.
All dashboards are now fully functional with no error messages displaying. Please contact support if you continue to experience any errors relating to this incident.
Affected services
Dashboard
Forms
Updated
Aug 28 at 04:45pm BST
A fix is rolling out to all accounts which will prevent this happening to new appointments.
The team is still working on restoring the affected appointments created within this time period.
Affected services
Dashboard
Forms
Created
Aug 28 at 02:37pm BST
We've identified an issue across our platform where appointments can be created without the associated patient data in some cases.
You may see errors regarding null patient nulls in your dashboard while we restore the missing data to your account.
Affected services
Dashboard
Forms