Back to overview
Degraded

Reports of double appointments being created

Sep 12 at 01:45pm BST
Affected services
Forms

Resolved
Sep 12 at 02:44pm BST

Forms are now patched and we are no longer creating extra appointments in some cases. Our team will continue to monitor appointment creation throughout the day.

Created
Sep 12 at 01:45pm BST

Forms are potentially creating the same booking multiple times on some accounts. We've been able to replicate the issue and a fix will be deployed shortly.